SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
All of our components are operating as expected and our team will continue to monitor our system.
Posted over 1 year ago. Mar 29, 2017 - 17:18 PDT
Identified
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted over 1 year ago. Mar 29, 2017 - 15:37 PDT