SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
The issue has now been resolved and all systems are operating as intended.
Posted over 1 year ago. Mar 24, 2017 - 16:18 PDT
Monitoring
All of our components are operating as expected and our team will continue to monitor our system.
Posted over 1 year ago. Mar 24, 2017 - 14:53 PDT
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted over 1 year ago. Mar 24, 2017 - 13:57 PDT