Service Issue
Incident Report for SaaSquatch
Resolved
All of our components are operating as expected and our team will continue to monitor our system.
Posted over 1 year ago. Mar 17, 2017 - 18:39 PDT
Monitoring
We deployed additional instances and it looks like all of our major components are available again and we are fully operational.
Posted over 1 year ago. Mar 17, 2017 - 18:08 PDT
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.
Posted over 1 year ago. Mar 17, 2017 - 17:46 PDT