SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
An investigation into the outage concluded that a specific legacy search functionality could cause an unintentionally large amount of data to be returned by a search query. This large response slowed down the system as it processed the data, causing a backlog of requests, and resulted in the experienced outage.

This specific legacy search functionality has since been updated so that it can no longer cause this issue.
We also took this opportunity to review the other search functionality in our system to ensure that similar, or related, problems don't happen in other parts of our system.

We apologize for any inconvenience this may have caused. If you have any additional questions or concerns about this please contact our support team at support@referralsaasquatch.com.
Posted 5 months ago. Jun 21, 2018 - 17:15 PDT
Monitoring
Our product team has identified the cause of the service issue, and has implemented steps to resolve it.

All of our components are now operating as expected, and we will continue to monitor our services closely until we are confident that all outstanding issues have been resolved.
Posted 5 months ago. Jun 19, 2018 - 11:15 PDT
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

The latest information about the status of this issue can also be found on our status page.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted 5 months ago. Jun 19, 2018 - 11:03 PDT
This incident affected: REST API, Admin Portal, and Referral Widget / squatch.js Library.