SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
A patch has been rolled out which has restored service to the SaaSquatch Admin Portal, REST API, and Widgets. We will continue to monitor each of these services closely until we are confident that all outstanding issues have been resolved.
Posted about 1 year ago. Oct 12, 2017 - 14:43 PDT
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted about 1 year ago. Oct 12, 2017 - 14:35 PDT