SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
The issue has now been resolved and all systems are operating as intended.
Posted 14 days ago. Feb 07, 2018 - 17:44 PST
Monitoring
Our product team has identified the cause of the service issue, and has implemented steps to resolve it.

All of our components are now operating as expected, and we will continue to monitor our services closely until we are confident that all outstanding issues have been resolved.
Posted 15 days ago. Feb 06, 2018 - 20:10 PST
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

The latest information about the status of this issue can also be found on our status page.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted 15 days ago. Feb 06, 2018 - 19:45 PST