SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
Our product team has completed their investigation of the incident, and has identified a memory leak in our application as the cause of the issue. The memory leak has since been patched, and the fix released.

During their investigation, our product team deployed additional resources to help reduce the impact of the issue, and the period of degraded performance was limited to a small time window on January 10th.

All systems are now operating as intended.
Posted 10 months ago. Jan 18, 2018 - 13:30 PST
Monitoring
Our product team has identified the cause of the service issue, and has implemented steps to resolve it.

All of our components are now operating as expected, and we will continue to monitor our services closely until we are confident that all outstanding issues have been resolved.
Posted 10 months ago. Jan 10, 2018 - 11:55 PST
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted 10 months ago. Jan 10, 2018 - 10:43 PST