Major Service Outage
Incident Report for SaaSquatch
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 02, 2019 - 17:55 PDT
Investigating
We're investigating an issue in one of our data centers that has resulted in request timeouts. Our data center provider is actively working to mitigate and restore service. We will continue to update you as we receive more information.

For more information: https://status.cloud.google.com/incident/cloud-networking/19009
Posted 5 months ago. Jun 02, 2019 - 14:11 PDT
This incident affected: REST API, Admin Portal, and Referral Widget / squatch.js Library.