Service Provider Unplanned Maintenance
Incident Report for SaaSquatch
Resolved
This incident has been resolved.
Posted over 1 year ago. May 18, 2017 - 20:14 PDT
Investigating
One of our service providers is performing unplanned maintenance which is affecting the SaaSquatch system. Our team is currently investigating and working towards a resolution.
Posted over 1 year ago. May 18, 2017 - 19:33 PDT